Chapter 2. 
    Installation
  




    Installing Qtractor can be done in two ways: from your
    distribution's software repository, or by building from source
    code. For most users, installing from your distribution's
    repositories is the right choice, as it offers the easiest install
    and ensures timely and reliable updates.
  
2.1. 
      Easy Install
    




      To install software from your distribution's repository, open
      the software installer for your distribution (often called
      Add/Remove Software or sometimes
      a Software Store).
    

      Search for Qtractor, and mark it for installation and proceed;
      there is no need to intall additional packages since the
      installer will automatically install any software required for
      Qtractor to run.
    


14.2. 
      Audio Clip Tools
    




    Outside of cleaning the sound of an audio clip, there are plenty
    of modifications you can do to the audio clips you record or
    import into Qtractor, such as
    splitting, punching-in, looping, and more.
  
14.2.1. 
      Moving Clips and Controlling Snapping
    




    You mouse cursor has four selection modes. Its default mode is
    Clip select, which allows you to click and
    drag clips within and between tracks. The precision with which you
    can move clips back and forward in time is determined by
    snapping. To deactivate or change snapping, click the
    View menu and select
    Snapping to choose the resolution you
    want to use when moving clips; you can move clips by beats,
    quarter notes, sixteenth notes, and so on, or none to deactivate
    snapping.
  

14.2.2. 
      Truncating (Splitting) and Extending Clips
    




    Also in clip mode, you can split audio clips nondestructively. To
    split a clip:
  
	
	Position the playhead in the timecode bar at the top of the
	Qtractor workspace to the position
	at which you'd like to split your audio clip.
      

	
	Click the clip you want to split so that it is selected.
      

	
	Click the Clip menu and choose
	Split. The clip has now been
	split at the position of the playhead.
      




    Since Qtractor never affects the
    original audio file it is referencing, any split you make to an
    audio clip is reversible. The easiest way to undo a clip (aside
    from using Edit >
    Undo) is to extend the clip. To extend
    a clip, click on the edge of the clip with your selection arrow
    and click and pull the edge to reveal more of the audio file
    within the track.
  
Note


      Extending or truncating clips by dragging the clip's edge is
      also affected by the Snap setting, so if
      you are having difficulty modifying the end or beginning of a
      clip, check to make snapping is deactivated.
    



    A second way to split clips is to use the Range or Rectangle
    selection tools.
  

14.2.3. 
      Range and Rectangle Selection
    




      The default selection tool is the Clip
      selection, which allows you to click on clips and select them as
      a whole so that you can move them within the workspace. The
      other two modes are Range and
      Rectangle.
    

      The Range selection tool spans all tracks
      in your workspace and allows you to arbitrarily select any
      portion of clips regardless of where the clips begin or end. In
      otherwords, you can select a range in the very middle of a clip,
      and all other clips above and below it because you are selecting
      a block of time, rather than basing your selection on the nature
      of the clips in your workspace.
    
[image: Using the range selection tool]

      To use the Range select mode:
    
	
	  Click the Edit menu >
	  Select Mode > Range
	

	
	  Click within an audio clip and drag your selection.
	




      The Rectangle selection mode is similar to
      Range but is track-specific. Using the
      Rectangle selection tool permits you to
      draw the range of selection over one or more tracks, and
      a selection will be made wherever a clip is present.
    

      To use the Rectangle select mode:
    
	
	  Click the Edit menu >
	  Select Mode > Rectangle
	

	
	  Click within an audio clip and drag your selection. You may
	  select portions, or the whole, of clips on as many tracks as
	  you wish. Or you may confine your selection to one.
	




      With both tools, your selected areas can be cut, copied, pasted,
      deleted, or even lifted out from their clips and moved elsewhere
      (the splits will be made automatically for you).
    

      To lift a selection from a clip or a set of clips, click and
      drag the selection.
    

      To copy and paste, click on the Edit menu and
      select Copy or
      Cut or the usual keyboard shortcuts
      of Ctrl+C
      or Ctrl+X. When you are ready to paste,
      click the Edit menu again and select
      Paste (or use
      Ctrl+V)
      and click in the time line where you want to paste the clips. 
    
Note


	If you have multiple clips copied, then they will be pasted
	relative to how they were copied (so if you paste a clip
	originally from tracks 1 and 2 into track 3, then the pasted
	clips will fall into tracks 3 and 4).
    



14.2.4. 
      Using Range Markers
    




      An alternate way to select a range in your workspace is with the
      marker transports, which appear in the timeline above the
      workspace alongside the play transport.
    
	
	  To bring the markers to your cursor, click in the timeline
	  above the Qtractor
	  workspace. Both the In- and Out- markers will appear at your
	  cursor's position.
	

	
	  The position of the markers is the out-point for what will
	  become your selection.  Move your cursor left and click
	  again to set the in-point.
	

	
	  The space between the two blue markers is now the active
	  range. Click the Edit menu and use the
	  options in the Select submenu to
	  select areas based on the currently active track, the range
	  spanning all tracks, and so on. You can also use this range
	  to define a loopable area, or to delete or copy and paste
	  its contents.
	




14.2.5. 
      Paste Repeat, or "Looping"
    




      In electronic music especially, there's a common need to record
      one or two measures and then loop those measures to create
      standardized basslines or drumbeats.
    

      The "right" way to achieve that would be to use a drum
      machine or a sequencer, which would literally play the same data
      (either pure MIDI data or audio samples) for as many measures as the
      composer programs. However, the effect can be emulated in
      Qtractor with a Paste
      Repeat, which allows you to copy an audio or MIDI
      clip and then paste it back-to-back for as many repetitions as
      you want.
    

      To perform a Paste Repeat:
    
	
	  Check your snapping settings in the View
	  menu (usually when looping clips, the user wants precision
	  snapping to the first clip's edge).
	

	
	  Click to select the clip you want to copy (or use a range
	  selection to extract a portion of the clip) and use
	  Edit > to
	  Copy the clip.
	

	
	  Click Edit and choose Paste
	  Repeat.
	

	
	  In the Paste Repeat window, enter the
	  number of iterations you want to paste, or the duration (in
	  timecode, frames, or beats) you need to fill with
	  repetitions. Click the OK button to
	  confirm.
	

	
	  Click in the timeline to complete the paste and anchor the
	  newly pasted clips in their track.
	




14.2.6. 
      Punch In/Out
    




      If one or two measures of a track doesn't quite measure up to
      your standards, you might want to re-record just those measures
      without having to record the entire track over. This process is
      called "punching in".
    
	
	  To perform a punch-in (and punch-out), use the
	  Range select tool or the range markers
	  to define a region of your timeline as the active area as
	  described in Section 14.2.3, “
      Range and Rectangle Selection
    ” and Section 14.2.4, “
      Using Range Markers
    ”
	

	
	  Once your range is set, click the Punch
	  In/Out button in the main toolbar, or use
	  the Transport menu and select
	  Punch Set.
	

	
	  Arm the recording destination track by clicking the
	  R button in the track list.
	

	
	  Click the Record button in the main
	  toolbar, and then the Play
	  button. Qtractor will play back your piece, and you can play
	  along but nothing you play will actually be recorded except
	  within the punch range. Recording will automatically stop
	  once the transport leaves the punch range.
	

	
	  To stop playback, click the Stop
	  button in the main toolbar, or use the
	  Spacebar.
	




      Punching in and out is a common task used in both MIDI and Audio
      recording.
    

14.2.7. 
    Looping Playback
  




    To play a section of your composition in a loop (often done so the
    musician can practise for a punch-in or improvise), select a range
    as in Section 14.2.3, “
      Range and Rectangle Selection
    ” and
    Section 14.2.4, “
      Using Range Markers
    ”
  

    Once your desired loop range is selected:
  
	
	Click on the Transport menu and select
	Set Loop. 
      

	
	Move the transport into the loop range, or start playing
	immediately; when the transport reaches the end of the loop
	range, it will return to the in-point of the loop and
	seamlessly continue playing until stopped.
      




14.2.8. 
      Simple Fades
    




      Fading in or out of an audio clip is common enough that there is
      a quick shortcut to achieve the effect on any clip. Notice in
      the top corner of any clip in the workspace there is a
      semi-transparent square node. Clicking and dragging this node
      further into the clip will create a fade in (if done at the
      beginning of a clip) or a fade out (if done at the end of a
      clip). The fade is given a slight curve to give it a more
      natural feel.
    

      Most of the time, these simple fades achieve the effect you need
      but should you desire finer control over your fades, see
      Chapter 18, 
    Automation
  .
    

14.2.9. 
      Merging Clips
    




      After a long day of editing, your workspace might start to look
      fragmented, with pieces of audio clips appearing in their tracks
      with long stretches of empty space. This is not necessarily a
      bad thing, but it does sometimes allow for accidental moves of
      precisely timed sound cues and it also may reflect a number of
      disparate files on your harddrive even though you consider the
      track one instance of music.
    

      By merging clips, you can change a number of clips into one
      consolidated file on your harddrive:
    
	
	  Select the clips within a track that you want to merge into
	  one.
	

	
	  Click the Clip menu and select
	  Merge.
	

	
	  In the Merge/Export window, enter a
	  new name for the merged file and save it to a logical
	  location on your harddrive.
	

	
	    The merged audio clip immediately replaces the old files
	    in your project.
	  





Chapter 17. 
      Effect Processors and Filters
    




      There are many theories, personal styles, and preferences when
      it comes to mixing a project. One producer might opt for no
      effects at all while another might use compressors, limiters,
      levellers, EQ, and more, and those same producers will abandon
      their style depending on what band they are dealing with.
    

      The best way to know what effects to use is to experiment;
      discover what different filters do, find out which ones you like
      or dislike, and do whatever your ear tells you to do.
    

      There are some staples in any audio engineer's toolkit, and
      between the Steve Harris LADSPA
      collection, CALF, and
      Jamin, you'll find everything you
      need to achieve the sound you want:
    
17.1. 
	Compressors
      




	As a sys admin has ssh and
	emacs, an audio producer has
	Dynamic Range Compressors. A compressor's job is to reduce
	loud sounds or to increase quiet sounds by reducing ( or
	"compressing") the signal's overall dynamic range. It
	has a number of uses in music production.
      

	A compressor on a track that is inconsistent in dynamics will
	produce a more consistent track that might be easier to mix
	into the rest of the piece, and also provide a better
	listening experience for the audience; it's difficult to
	follow the lyrics of a song, for example, when the voice track
	continually drops behind the other instruments.
      

	Compressors are very common on drums, as well, since when
	drums are mixed the loudest hits and crashes tend to rise to
	the surface while all the subtleties, like little touches of
	ornamentation and the decays of drum and cymbal hits, are
	lost. A compressor will even out the range between those
	softer sounds and the harder sounds, so you still get the
	hard-hitting beats but get to keep the personality.
      

	There are at least three good compressors for GNU Linux:
      
17.1.1. 
	  CALF
	




	  The Calf plugin suite contains a
	  compressor which you can use either as a plugin from within
	  Qtractor or as a stand-alone app
	  as an Aux Send/Return. Its features are typical of an
	  all-purpose, general-use compressor, and running its full
	  GUI with calfjackhost might help
	  you understand the theory behind compression if you are new
	  to it.
	
[image: The Calf Compressor]

	  If you are new to compressors, try this experiment:
	
	
	      Open the CALF compressor by launching
	      calfjackhost. Click on the
	      Add plugin menu and choose
	      Compressor.
	    

	
	      To launch the user interface, click the
	      Compressor button in the lower
	      left. Change the settings to:
	    
	
		    Ratio to 1
		  

	
		    Makeup gain to 0dB
		  

	
		    Threshold to -43.2 
		  

	
		    Knee to 0dB
		  




		Notice that this causes the green line to align
		perfectly with the gray line that runs diagonally
		through the compressor screen.
	    

	      This achieves, essentially, a pass-through effect. You
	      have set a limit for every possible level of sound equal
	      to itself, and since no possible level of sound will
	      ever be greater than itself, nothing will be constrained.
	    

	
	      Now change the ratio to approximately 2 (a 2:1 ratio).
	    

	      Notice the green line now deviates from the gray normal
	      line; you may think of the green line as a sort of
	      ceiling. Measuring soundwaves by the numbers along the
	      X-axis, you can see that 24dB in the input (ie, the gray
	      line), it will be constrained down to 0dB (along the
	      green line).
	    

	      Accordingly, a soundwave that reaches -12dB will be
	      constrained to -24db.
	    

	
	      For one last demonstration, turn the
	      Ratio knob all the way to right
	      so it reads +inf and the
	      Threshold knob all the way to the right
	      so it reads 0dB. 
	    

	      This places a hard ceiling at the current threshold
	      setting. This means that any sound louder than the
	      threshold will be constrained to that level, no matter
	      what. Set too severly this can cause a clipped sound,
	      but the concept of leveling is ubiquitous in production,
	      as a safeguard to ensure that the levels do not go over
	      0dB.
	    

	
	      When exactly compression kicks in is controlled by
	      the Threshold value. Try
	      adjusting the threshold knob and notice that the bend
	      (or "knee") in the green line changes.
	    

	      Turn the Ratio knob back to 2 and
	      set the Threshold to -12dB.
	    

	      Setting the threshold to -12dB means that
	      everything below -12dB will remain unchanged, while
	      anything above -12dB will be constrained to some degree
	      (depending on the ratio setting, of course).
	    

	
	      Make the Knee more gradual and
	      natural by adjusting the knee to 18dB; this gives a
	      softer curve to the compression. Sometimes this is
	      intentionally not increased, and a sharper knee is
	      desired (it's a trick sometimes used in compressing
	      drums, to create hits that "pop").
	    

	
	      The Makeup Gain knob, currently
	      set to 0, allows you to boost the output sound to
	      account for the inherent loss in volume when using a
	      compressor that constrains levels.
	    

	
	      The Attack and
	      Release knobs control how quickly
	      the compression effect takes to take full effect, and
	      how quickly the effect is released.
	    

	      In otherwords, at a 0ms attack, a soundwave will be
	      constrained the very moment it pushes toward the
	      threshold setting. The result of this is often a very
	      harsh and noticeable effect, usually undesirable
	      (except, again, for some stylistic choice sometimes made
	      on drum kits or special effects).
	    

	      Setting the attack to 500ms (.5 second), for instance,
	      renders a softer, more gradual effect that better allows
	      a soundwave to retain its natural shape and curve but
	      still suppressing it under the threshold's level.
	    




	  Once you've designed good compression settings, save it as a
	  preset by clicking on the Preset menu and
	  choosing Store preset
	  selection. You will need the preset saved (perhaps in your
	  Qtractor project folder for
	  better organization) since
	  Qtractor obviously will not save
	  or preserve your settings.
	

	  The Calf compressor is a capable
	  and user-friendly compressor unit, available either as a
	  stand-alone unit or a plugin from within
	  Qtractor, so use it often!
	

17.1.2. 
	  Steve Harris LADSPA Dyson Compressor
	




	  The Dyson Compressor is included
	  in the Steve Harris set of LADSPA
	  plugins. It is very basic, with few adjustable settings, but
	  if quick and basic compression is all you need then it may
	  just be what you need.
	

	  Use the Dyson compressor as you would any other LADSPA
	  plugin in Qtractor. Its interface
	  offers four sliders for customization: the peak limit (ie,
	  threshold), release time (in seconds), the fast compression
	  ratio, and the compression ratio (both ratios are counted
	  from 0 to 1, so some math is required, with 1:1 ratio being
	  equal to 0).
	

17.1.3. 
	  Jamin
	




	  The Jamin mastering application
	  contains one of the most powerful compressors
	  available. Whereas the Calf
	  compressor excels in its simplicity,
	  Jamin provides three separate
	  compressors, essentially, for the Low, Mid, and Hi
	  frequencies of your input.
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	  This obviously allows for a far greater degree of
	  fine-tuning. As for what Jamin
	  defines as a low, mid, or hi frequency: even these are
	  adjustable with the middle horizontal
	  Crossover sliders.
	

	  Your familiar Attack, Release, Threshold, Ratio, Knee, and
	  Makeup Gain controls are found at the bottom of the window
	  in the form of vertical sliders.
	

	  As with the stand-alone version of
	  Calf,
	  Jamin is used as an Aux
	  Send/Return; unlike Calf, it
	  has no plugin option.
	

	  Because Jamin also features a
	  full-featured 30-band EQ, it might be best treated as the
	  compressor/EQ filter for the
	  Qtractor's Master Out; something
	  that Jamin obviously intends
	  since it is advertised as a mastering application.
	

	  As with the stand-alone version of
	  Calf compressor, you can and
	  should save your presets in Jamin
	  by clicking on the File menu and
	  selecting Save As
	



Chapter 19. 
      Delivery
    




      At the end of the song-writing process, there is the final
      export.  This of course combines all of the sounds being
      generated from all of the different sources you may be using,
      filtered through all of the effects and processors you have in
      place, and places them all into a self-contained file that your
      audience can play in their media player of choice.
    

      Since everything in Qtractor is
      routed through its mixer, to combine the sounds into one audio
      file is as simple as creating a new track and using it to record
      the Master Out:
    
	
	Go to the View menu and select
	Options to open
	Qtractor's preferences.
      

	
	  In the Options window, click on the
	  Audio tab. Select the kind of audio
	  you'd like to use for your recording. It is generally
	  prefered to export to a lossless format and use that file as
	  the "gold master" from which compressed (ogg vorbis,
	  mp4, mp3, and so on) versions can be produced. A high
	  quality, lossless, free codec is FLAC.
	

	
	  Click the OK button to accept your changes.
	

	
	  Create a new track in your
	  Qtractor project by clicking the
	  Track menu and selecting Add
	  Track.
	

	
	In the Mixer window, right click the
	plugin window and click the Inserts
	category, choosing Add Insert.    
	

	  In the Insert window, click the
	  Return button. This opens a
	  Connections window.
	

	
	  Click the first (left) Master In jack
	  in the left column to the first insert of your new track in
	  the right column, and click the
	  Connect button. Repeat this for the
	  second (right) jacks. Close the window when finished.
	

	
	  You have now routed all of your mixer's outbound sound to
	  the input of your new track. Arm your new track for
	  recording by clicking the R button
	  either in the track list or the mixer window.
	

	
	  Position the transport (playhead) at the beginning of the
	  project (or the beginning of the portion of your song you
	  intend to export).
	
Note


	  You may wish to set an in and out point so that the
	  recording stops automatically, or you may prefer to stop the
	  recording manually.
	



	
	  Press the Record button in the top
	  menu bar.
	
Warning


	    Before recording, double check your connections! If you
	    have left a microphone plugged in and actively sending
	    input to your Master in, for example,
	    you might find later that you've recorded a layer of room
	    tone behind all of your tracks!
	  



	
	  Press the Play button to begin
	  playback and recording.
	

	
	  When recording is finished, select the track by clicking on
	  the new audio clip in the
	  Qtractor project. Click the
	  Clip menu and select
	  Export to send the clip out as an
	  independent file.
	




      Your project is now complete. Create a new project file, and
      start over with your next song, and enjoy your time with Qtractor.
    


  General MIDI Instrumentation





  This is the standardized list of General MIDI channels and the
  corresponding instrumentation. If you are composing using MIDI and
  want your piece to call a standard set of instruments so that it
  will sound the same across all systems, this is the list to use.


  Distributing MIDI files of renditions of popular songs was fairly
  common in the early days of the Internet, when it was considered
  technologically advanced to have a MIDI song autoatically play in
  the background when someone visited one's homepage. With General
  MIDI, it could be ensured that the song sounded more or less the
  same no matter whose system it was.


  Of course, this is rather rarely done now. It is far more common to
  use MIDI to trigger sounds and instruments in any format that works
  best for you, then to record the music and re-distribute the ogg or
  mp3 version.


  Even so, this is a good reference list since General MIDI was widely
  used at one point.

	
 Acoustic Grand Piano


	
 Bright Acoustic Piano


	
 Electric Grand Piano


	
 Honky-tonk Piano


	
 Electric Piano 1


	
 Electric Piano 2


	
 Harpsichord


	
 Clavinet


	
 Celesta


	
 Glockenspiel


	
 Music Box


	
 Vibraphone


	
 Marimba


	
 Xylophone


	
 Tubular Bells


	
 Dulcimer


	
 Drawbar Organ


	
 Percussive Organ


	
 Rock Organ


	
 Church Organ


	
 Reed Organ


	
 Accordion


	
 Harmonica


	
 Tango Accordion


	
 Acoustic Guitar (nylon)


	
 Acoustic Guitar (steel)


	
 Electric Guitar (jazz)


	
 Electric Guitar (clean)


	
 Electric Guitar (muted)


	
 Overdriven Guitar


	
 Distortion Guitar


	
 Guitar harmonics


	
 Acoustic Bass


	
 Electric Bass (finger)


	
 Electric Bass (pick)


	
 Fretless Bass


	
 Slap Bass 1


	
 Slap Bass 2


	
 Synth Bass 1


	
 Synth Bass 2


	
 Violin


	
 Viola


	
 Cello


	
 Contrabass


	
 Tremolo Strings


	
 Pizzicato Strings


	
 Orchestral Harp


	
 Timpani


	
 String Ensemble 1


	
 String Ensemble 2


	
 Synth Strings 1


	
 Synth Strings 2


	
 Choir Aahs


	
 Voice Oohs


	
 Synth Voice


	
 Orchestra Hit


	
 Trumpet


	
 Trombone


	
 Tuba


	
 Muted Trumpet


	
 French Horn


	
 Brass Section


	
 Synth Brass 1


	
 Synth Brass 2


	
 Soprano Sax


	
 Alto Sax


	
 Tenor Sax


	
 Baritone Sax


	
 Oboe


	
 English Horn


	
 Bassoon


	
 Clarinet


	
 Piccolo


	
 Flute


	
 Recorder


	
 Pan Flute


	
 Blown Bottle


	
 Shakuhachi


	
 Whistle


	
 Ocarina


	
 Lead 1 (square)


	
 Lead 2 (sawtooth)


	
 Lead 3 (calliope)


	
 Lead 4 (chiff)


	
 Lead 5 (charang)


	
 Lead 6 (vox)


	
 Lead 7 (fifths)


	
 Lead 8 (lead bass)


	
 Pad 1 (new age)


	
 Pad 2 (warm)


	
 Pad 3 (polysynth)


	
 Pad 4 (choir)


	
 Pad 5 (bowed)


	
 Pad 6 (metal)


	
 Pad 7 (halo)


	
 Pad 8 (sweep)


	
 FX 1 (rain)


	
 FX 2 (soundtrack)


	
 FX 3 (crystal)


	
 FX 4 (atmosphere)


	
 FX 5 (brightness)


	
 FX 6 (goblins)


	
 FX 7 (echoes)


	
 FX 8 (sci fi)


	
 Sitar


	
 Banjo


	
 Shamisen


	
 Koto


	
 Kalimba


	
 Bag pipe


	
 Fiddle


	
 Shanai


	
 Tinkle Bell


	
 Agogo


	
 Steel Drums


	
 Woodblock


	
 Taiko Drum


	
 Melodic Tom


	
 Synth Drum


	
 Reverse Cymbal


	
 Guitar Fret Noise


	
 Breath Noise


	
 Seashore


	
 Bird Tweet


	
 Telephone Ring


	
 Helicopter


	
 Applause


	
 Gunshot





