You are here

no lv2 plugins are shown

i compiled successfully qtractor on ubuntu 18.04 and started it after loading jack.
at first i had 3 plugin types: ladspa, vst and lv2.

i updated something an now i do not have lv2 any more in the list.

should i recompile?

after recompiling my ubuntu settings button disappered.
my jackd is also not available any more ;-(

i had to install jackd again and now i can use it again
sudo apt-get install jackd qjackctl

my settings i get back with
sudo apt-get install gnome-control-center

but LV2 is still missing

if i perform rescan i get following message

qtractor_ladspa_scan: /home/bigjuergo/Documents/lmms/plugins/ladspa/ plugin file error.
qtractor_ladspa_scan: /usr/lib/ladspa/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
[31mCarla assertion failure: "shmIds != nullptr && std::strlen(shmIds) == 6*4" in file libjack.cpp, line 133[0m
qtractor_vst_scan: /usr/lib/vst/carla.vst/jack/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
qtractor_vst_scan: /usr/lib/vst/carla.vst/ plugin file error.
lo server running on 10686
lo server running on 12189

is this normal?

thank you for help i am a qtractor beginner at the moment.

rncbc's picture

please pay attention to the configure report you get when building qtractor from source; some libraries or packages needed for LV2 plug-in support might be missing, especially liblilv-dev and/or its direct dependencies, libsratom-dev, libsord-dev, libserd-dev.

the output from qtractor_vst_scan is considered normal as carla.vst has some files (.so) which are not exactly a VST plug-in file but library components of some sort.


my install procedere was like this:

sudo apt-get install qt5-default
sudo apt-get install libqt5x11extras5-dev
sudo apt-get install jackd
sudo apt-get install libjack-dev
sudo apt-get install libasound2-dev
sudo apt-get install libsndfile1-dev
sudo apt-get install liblrdf0-dev
sudo apt-get install qttools5-dev-tools

Source Code:
Extract source code in downloads folder

Compile and Install
cd qtractor
sudo make install

Enable Realtime Mode for Jack
sudo nano /etc/security/limits.conf
add line: @audio - rtprio 99
sudo usermod -a -G audio username
logout and login

Launch Program

i will now reinstall ubuntu 18.04 and perform compile again, hope it works, because i like the concept of qtractor very much.

rncbc's picture

as said, remember to install lv2-dev, liblilv-dev and all dependencies, libsratom-dev, libsord-dev, libserd-dev if you wish LV2 plug-in support;

also libsuil-dev and libgtk2.0-dev in case the Calf plug-ins GUIs are to run and shown properly.


trblft's picture

Hi, have you read this? Will it have an impact on Qtractor or the V1 suite?

rncbc's picture

yes, I know of this ardour stance and no, qtractor won't subscribe to that nor will it be impacted whatsoever.

all the vee-ones do work and show nicely on ardour5 (and ardour6) *iif* you use or it's built and linked to the most recent libSUIL (qt5_on_gtk2 >= 0.10.2); otherwise you might be interested to read these words of advice for ardour users.


trblft's picture

"In the not too distant future we will likely drop support for QT GUIs (and GTK plugin GUIs) and only support native UIs and self-contained plugins that do not depend on external libraries." Said this member of LV2 Dev Team. Does "self contained" applies to V1 suite?

rncbc's picture

A rather political call from ardour dev, not mine, I assure you. One that will backfire to them anyhow.

Of course they're free to dismiss all support if you run plugins that do not comply with their view.

Which is in fact the policy in question. It boils down to this:"you only get our devs support if you run our sanctioned build, so sorry" tell, that kind of stance is not, never was, never will be one of mine.


Add new comment