You are here

qjackctl don't start with m-audio transit usb (ubuntustudio 14.04)

AttachmentSize
Image icon hw:USB202.35 KB
Image icon hw:USB,1155.6 KB

I can't run qjacktctl using m-audio transit usb in ubuntustudio 14.04
Message says:
Fri Aug 8 13:38:53 2014: Starting jack server...
Fri Aug 8 13:38:53 2014: JACK server starting in realtime mode with priority 10
Fri Aug 8 13:38:54 2014: Acquired audio card Audio1
Fri Aug 8 13:38:54 2014: creating alsa driver ... hw:USB|hw:USB|128|2|44100|2|2|nomon|swmeter|-|32bit
Fri Aug 8 13:38:54 2014: configuring for 44100Hz, period = 128 frames (2.9 ms), buffer = 2 periods
Fri Aug 8 13:38:54 2014: ALSA: final selected sample format for capture: 24bit little-endian
Fri Aug 8 13:38:54 2014: ALSA: use 2 periods for capture
Fri Aug 8 13:38:54 2014: ALSA: final selected sample format for playback: 24bit little-endian
Fri Aug 8 13:38:54 2014: ALSA: use 2 periods for playback
Fri Aug 8 13:38:54 2014: ERROR: ALSA: prepare error for playback on "hw:USB" (Broken pipe)
Fri Aug 8 13:38:54 2014: ERROR: JackAudioDriver::ProcessAsync: read error, stopping...
Cannot connect to server socket err = No existe el archivo o el directorio
Cannot connect to server request channel
jack server is not running or cannot be started
Fri Aug 8 13:38:59 2014: ERROR: JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Fri Aug 8 13:38:59 2014: ERROR: Driver is not running
Fri Aug 8 13:38:59 2014: ERROR: Cannot open client name = dbusapi
Fri Aug 8 13:38:59 2014: ERROR: failed to create dbusapi jack client
Fri Aug 8 13:38:59 2014: Released audio card Audio1
Fri Aug 8 13:38:59 2014: Saving settings to "/home/oscar/.config/jack/conf.xml" ...
13:39:01.796 No puede conectarse al servidor JACK como cliente. - La operación global falló. - No puede conectarse al servidor. Por favor revise la ventana de mensajes para mas información.
Cannot connect to server socket err = No existe el archivo o el directorio
Cannot connect to server request channel
jack server is not running or cannot be started

And when I set hw:USB,1 the server starts but audio don't work
Fri Aug 8 13:56:40 2014: Starting jack server...
Fri Aug 8 13:56:40 2014: JACK server starting in realtime mode with priority 10
Fri Aug 8 13:56:40 2014: Acquired audio card Audio1
Fri Aug 8 13:56:40 2014: creating alsa driver ... hw:USB,1|hw:USB|128|2|44100|2|2|nomon|swmeter|-|32bit
Fri Aug 8 13:56:40 2014: configuring for 44100Hz, period = 128 frames (2.9 ms), buffer = 2 periods
Fri Aug 8 13:56:40 2014: ALSA: final selected sample format for capture: 24bit little-endian
Fri Aug 8 13:56:40 2014: ALSA: use 2 periods for capture
Fri Aug 8 13:56:40 2014: ALSA: final selected sample format for playback: 16bit little-endian
Fri Aug 8 13:56:40 2014: ALSA: use 2 periods for playback
Fri Aug 8 13:56:40 2014: graph reorder: new port 'system:capture_1'
Fri Aug 8 13:56:40 2014: New client 'system' with PID 0
Fri Aug 8 13:56:40 2014: graph reorder: new port 'system:capture_2'
Fri Aug 8 13:56:40 2014: graph reorder: new port 'system:playback_1'
Fri Aug 8 13:56:40 2014: graph reorder: new port 'system:playback_2'
Fri Aug 8 13:56:40 2014: New client 'PulseAudio JACK Sink' with PID 1733
Fri Aug 8 13:56:41 2014: Connecting 'PulseAudio JACK Sink:front-left' to 'system:playback_1'
Fri Aug 8 13:56:41 2014: Connecting 'PulseAudio JACK Sink:front-right' to 'system:playback_2'
Fri Aug 8 13:56:41 2014: New client 'PulseAudio JACK Source' with PID 1733
Fri Aug 8 13:56:41 2014: Connecting 'system:capture_1' to 'PulseAudio JACK Source:front-left'
Fri Aug 8 13:56:41 2014: Connecting 'system:capture_2' to 'PulseAudio JACK Source:front-right'
13:56:43.192 Cambios en las conexiones JACK.
13:56:43.199 Configuración del servidor salvada en "/home/oscar/.jackdrc".
13:56:43.203 Reiniciar estadísticas.
13:56:43.219 Cliente activado.
Fri Aug 8 13:56:42 2014: Saving settings to "/home/oscar/.config/jack/conf.xml" ...
13:56:43.261 Cambió el gráfico de conexiones de JACK.
Fri Aug 8 13:56:43 2014: New client 'qjackctl' with PID 7361
13:56:47.387 XRUN callback (1).
13:56:54.145 XRUN callback (2).
13:57:00.273 Cambió el gráfico de conexiones de JACK.
13:57:00.354 Cambios en las conexiones JACK.
13:57:00.362 Cambió el gráfico de conexiones de JACK.
Fri Aug 8 13:57:00 2014: New client 'pd_extended_0' with PID 8085
Fri Aug 8 13:57:00 2014: Connecting 'system:capture_1' to 'pd_extended_0:input0'
Fri Aug 8 13:57:00 2014: Connecting 'system:capture_2' to 'pd_extended_0:input1'
Fri Aug 8 13:57:00 2014: Connecting 'pd_extended_0:output0' to 'system:playback_1'
Fri Aug 8 13:57:00 2014: Connecting 'pd_extended_0:output1' to 'system:playback_2'
13:57:27.245 XRUN callback (3).

M-Audio works fine with other application like media players (audacious)
In Ubuntu 12.04 I didn't have this problem.

Forums: 
rncbc's picture

hi, you seem to have an exotic sound device there;

1. i can see you're using the jackdbus (D-Bus) interface; try not to at first: turn Setup/Misc/Other/Enable D-Bus interface off and try again.
2. you should try first setting Setup/Settings/Parameters/Interface = "hw:USB" and reset both Input/Output device to "(default)" or blank.
3. one recommendation for USB devices is also trying with Setup/Settings/Parameters/Sample Rate = 48000 and Periods/Buffer = 3.

hth.
cheers

i have a similar problem with the Onyx Blackjack USB audio interface:

now when i rig up with qjackctl and rakarrack, they insist on using the laptop mic/speakers for input and output. even when i tell qjackctl to use the USB audio interface instead

this is on OS based on ubuntu 14.04 (had no problems under 12.04)

tried rncbc suggestions, which looked like a potential breakthrough

tried uninstalling and killing pulseaudio

but still the problem persists!

rncbc's picture

please post the qjackctl/messages window output that find right after you try to start jackd, just like the OP above.

also post a screenshot of your qjackctl/setup/settings tab; and finally, show us the output of `cat /proc/asound/cards` from the command line console.

byee

sec's picture

08:27:58.684 Patchbay deactivated.
08:27:58.685 Statistics reset.
08:27:58.693 ALSA connection change.
08:27:58.749 JACK connection change.
08:27:58.762 Client activated.
(qjackctl:3798): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:3798): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:3798): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:3798): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

ubuntu-studio@ubuntu-studio:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf2520000 irq 44
1 [Blackjack ]: USB-Audio - Onyx Blackjack
Loud Technologies Inc. Onyx Blackjack at usb-0000:00:1d.0-1.1, full speed
29 [ThinkPadEC ]: ThinkPad EC - ThinkPad Console Audio Control
ThinkPad Console Audio Control at EC reg 0x30, fw unknown

The qjackctl settings: http://postimg.org/image/8m7nimhep/

all defaults, except I change the interface to hw:Blackjack and disable D-Bus interface. (I have also tried with D-Bus enabled, also with modifying input and output device, also with suggestions on samplerate and buffer.)

thx

p.s. as i mentioned, no problems in trisquel 6 (based on ubuntu 12.04) but i have this same problem in trisquel 7 (based on 14.04) and in ubuntu studio 14.04 liveusb

rncbc's picture

the messages output kind of indicates that qjackctl is NOT starting the jack-server at all; maybe it's already started ?
please do, from a command-line console, the following:

killall -9 qjackctl
killall -9 jackd
killall -9 jackdbus
pulseaudio -k

and try again.

byee

Add new comment