You are here

fluidsynth-dssi not restoring after session save/load

AttachmentSize
Binary Data fluidTest_pre.qtz1.83 KB
Binary Data fluidTest_post.qtz1.7 KB

Hi Rui,

I'm having a couple of issues with qtractor and qjackctl with an install on a new machine. I'll post the qjackctl issue separately in its section of the forum following this.

When opening the fluidsynth-dssi gui via the Mixer, it's displayed correctly and I can load a soundfont and change options. The soundfont also plays correctly. However, when I re-open the gui all information has been reset to default - no soundfont loaded, default options. Even so, the audio still plays correctly - it's just the gui that's been reset. Something similar happened a couple of years ago.

When reloading the project via File > Open Recent, the audio is still OK (but gui still reset to defaults, as before). However, after making an arbitrary change (e.g. solo/unsolo a track), saving, then reloading via File > Open Recent, no audio will play. i.e. Qtractor/fluidsynth-dssi seem to remain in the "audio playing" state only until the session is altered and re-saved/re-loaded.

FYI, when closing the GUI I get the below in Qtractor's messages, but I've had this for ages so I imagine it may not be relevant to this:

(FluidSynth-DSSI_gtk:6310): GLib-CRITICAL **: Source ID 7 was not found when attempting to remove it

I've attached 2 simple qtz files:

1) fluidTest_pre.qtz: after initially loading the soundfont/changing options
2) fluidTest_post.qtz: after making a change in the session and resaving the session

You'll see that, in fluidTest_post.qtz, the configs area (at least) has the patch etc. info missing.

I got the packages from your https://www.rncbc.org/archive/:

libfluidsynth-devel-2.0.3-15.rncbc.suse.x86_64.rpm
fluidsynth-dssi-1.1.0-4.rncbc.suse.x86_64.rpm
fluidsynth-2.0.3-15.rncbc.suse.x86_64.rpm

I also have a libfludsynth1 (1.1.11-lp150.1.1) installed, which was pulled in by YaST (I'm on opensuse like you) when I installed lv2-calf. Is there any problem with having both this and your libfluidsynth2? I tried temporarily uninstalling it but it made no difference to the above problem.

I'm running the latest git version of qtractor.

Thanks as ever.

Forums: 

You can ignore this bit. It seems it's fine now after resetting QjackCtl.conf :-)

rncbc's picture

oops!

this seems a bad move in the latest v0.9.4 indeed! v0.9.3 seems not to be suffering from this issue.

have to run git bisect on this :(

byee

[UPDATE:] Maybe fixed on qtractor-0.9.4.2git.3bc6f2. thanks.

Looks fixed - thanks :-)

BTW, is it OK to have both libfluidsynth1/2 installed? I haven't seen any ill effects with this, but don't think I've ever needed it before.

rncbc's picture

yes, as long you have no dependencies on libfluidsynth1 you can get rid of it.

cheers

OK, thanks. It seems lv2-calf needs it so I'll keep things as they are if it's no problem to have.

Add new comment