You are here

No Content / Links in Menus

Hi everyone, am new here.
I installed Qtractor on an intel i5 Surface Pro, on Fedora 29 & Feodora 30.
The Menus at the top of the screen are tiny, barely able to read them, and I see no way to sort that,
but the worst thing is, there is no content / links in them when I click on them, no matter right left of middle click,
a box extends with a border, but no content or links, I added a track, and an mp3.
and still no links appear in the menus.

I would like to try Qtractor on my laptop which runs the latest up to date version of Lubuntu, it runs reaper flawlessly,
have no desire to try Ardour used it on other projects, small menu at top makes it unusable for me, Reaper works as
the menus can be resized as can their layout, line spacing font margins and such, but I cant find a way to alter Qtractor
menu sizes to make them readable, and in any event, there are no links available when the main links are clicked,
I did highlight parts of the track but no menu choices popped up, just an outlined box with no content / links.

Maybe this is a simple enough fix, if anyone knows what is up, I would love to hear from you.

Thanks and regards to you all

Forums: 
rncbc's picture

wow, it is the first time i hear somthing like this...

wait, i remember the "windows" widget style having this behavior...could it be that it is the default qt5 style in your desktop environment?

please try launching qtractor from a terminal/console command line, as follows:

qtractor -style Fusion

if that works the above theory is right: just set (main menu View > Options... > Display > Custom) Widget style theme to anything but "(default)" or "Windows" ("Fusion" is of course my favorite).

hth.
cheers

Thanks for replying, I typed the code, preceded with sudo, entered a password, got an error
about no output to 0 something or other, I forgot the exact error as I tried again without sudo
and the program opened, but still no change, no menu lists / links.

[xyz@localhost ~]$ sudo qtractor -style Fusion
[sudo] password for xyz:
No protocol specified
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted
[xyz@localhost ~]$ qtractor -style Fusion
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(qtractor:2443): GLib-GObject-WARNING **: 19:21:28.098: g_object_get_is_valid_property: object class 'GtkSettings' has no property named 'gtk-long-press-time'

(qtractor:2443): GLib-GObject-WARNING **: 19:21:28.098: g_object_get_is_valid_property: object class 'GtkSettings' has no property named 'gtk-application-prefer-dark-theme'

rncbc's picture

again from the command line, please show:

qtractor -v

and please tell from where and how exact did you get your package installed ?

I installed using sudo dnf install qtractor

[xyw@localhost ~]$ sudo dnf install qtractor
Last metadata expiration check: 0:00:52 ago on Sat 17 Oct 2020 20:03:54 IST.
Dependencies resolved.
================================================================================
Package Architecture Version Repository Size
================================================================================
Installing:
qtractor x86_64 0.9.10-1.fc30 updates 1.9 M

Transaction Summary
================================================================================
Install 1 Package

Total download size: 1.9 M
Installed size: 7.3 M
Is this ok [y/N]: y
Downloading Packages:
qtractor-0.9.10-1.fc30.x86_64.rpm 222 kB/s | 1.9 MB 00:08
--------------------------------------------------------------------------------
Total 178 kB/s | 1.9 MB 00:10
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : qtractor-0.9.10-1.fc30.x86_64 1/1
Running scriptlet: qtractor-0.9.10-1.fc30.x86_64 1/1
Verifying : qtractor-0.9.10-1.fc30.x86_64 1/1

Installed:
qtractor-0.9.10-1.fc30.x86_64

Complete!
[xyz@localhost ~]$ sudo dnf update

**************** qtractor -v ***********************************
[xyz@localhost ~]$ qtractor -v
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(qtractor:3166): GLib-GObject-WARNING **: 20:45:55.038: g_object_get_is_valid_property: object class 'GtkSettings' has no property named 'gtk-long-press-time'

(qtractor:3166): GLib-GObject-WARNING **: 20:45:55.039: g_object_get_is_valid_property: object class 'GtkSettings' has no property named 'gtk-application-prefer-dark-theme'
Qt: 5.12.5
Qtractor: 0.9.10

rncbc's picture

well, v0.9.10 is kinda old, so is Fedora 30 I suppose... isn't that out-of-support already?

what happens if you try the latest released AppImage?

qtractor-0.9.17-58.x86_64.AppImage

does it run at all? does it show no drop-menus menus as the fc30 package?

seeya

Here is the output from the panel at the bottom of the qtractor scteen,
I made the appimage executable, ran it and the following happened,

Session closed.
Session started.
New session: "Untitled1".
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
no message buffer overruns
no message buffer overruns
no message buffer overruns
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 20
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:HDMI,3|hw:HDMI,3|1024|2|44100|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
QCommonStyle::drawComplexControl: Control 1 not handled
MIDI connections change.
Audio connections change.
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled

I do not know that the above not handled means.
I will load an audio track and see how things go, the qtractor screen has icons
that were not there before, and content when clicked upon.

UPDATE
I shutdown qtractor, restarted jackctl, opened qtractor and have sound.
I still have a blank box when I middle click on a track, not sure why this is,
should there be some dialog or options showing, or is this normal for qtractocr.
I can't seem to add a png of the screen shot, so am struggling to explain.
I also don't understand why the appimage worked, and the dnf install did not.
I also tried to ./configure the latest release from the Qtractor site, that failed too
with an error about not resolving something, it was late and I gave up too.

Hopefully this app image will do the trick

Add new comment