You are here

Mixer volume not honored upon initial loading of project

I've been working around what feels like a bug for some time now and finally decided I should stop and report it.

So for a given track, I've got the mixer volume pulled down to 50 %. I save my work, life is good.

I come back later, open the file and upon playing the track, I notice volume is at 100 % (mixer track still shows the intended 50%).

My work-around has been to "nudge" each of these non-100% tracks in order to get things sounding the way they should. Of course, this is horrible.

I should also point out that from a MIDI perspective, all my tracks are driving carla-hosted plugins via dedicated MIDI busses. I've taken care to configure each plugin's MIDI abilities as shown in the attached image. As a result, every day operations are always reliable aside from this one issue involving the initial "seeding" of each track's volume.

20 years ago, I'd have just set a CC=7 value for each track at 00:00:00 but that feels shameful now. Am I nuts to think Qtractor should be sending an initial MIDI controller event when the track begins playing based off the state of the track's volume in the mixer? If not, how is this supposed to work?

Thanks in advance for any insight

AttachmentSize
Image icon Screenshot_2021-07-08_00-07-08.png71.48 KB
Forums: 
rncbc's picture

Am I nuts to think Qtractor should be sending an initial MIDI controller event when the track begins playing based off the state of the track's volume in the mixer?

and that's exactly what it does: it sends MIDI track's volume (CC#7) and panning CC#10 as well, at the start of playback; the values that are sent are the ones set on the MIDI track's mixer strip sliders.

however, if there are any CC#7 (or CC#10) channel events inscribed in the MIDI sequence, file or clip, they will be sent to the target devices alright--why wouldn't they?--and that just might not get reflected to the mixer strips sliders at all! I'm pretty sure it is not:) but them both might affect the target device which I think is some Carla hosted plugin in your case.

hth.
cheers

Thanks for the confirmation. When I have some time, I'll insert something that'll show me the messages being sent and report back. I just need to understand why I have to resort to "nudging" the slider in order for desired volume to take effect.

Add new comment