You are here

Playback vs. export clipping

Hi - This may be a novice question, but I always wondered why I never hear clipping when playing tracks that are hot, but when I export them, I get lots of clipping. I understand that I should not let them get hot, but it doesn't make sense to me why clipping can't be heard on playback. Anybody care to educate me? :) Thanks!

Forums: 
rncbc's picture

It actually depends on the exported file sample format: if not a 32-bit float, the pcm signal gets hard-clipped/damaged if it tips over 0dBfs.

IOW. When not doing final mastering, you're here recommended to either use:
a. WAV Microsoft: Float 32/64-bit (lossless);
b. FLAC Free Lossless Audio Codec: Float 32/64-bit (also lossless as name implies);
c. OGG Vorbis: Float 32-bit by definition (lossy).

byee

EDIT: removed FLAC as it doesn't support Float 32/64-bit.

Interesting. What prompted me to ask is that I finally went up to 48khz 32 bit float... No clipping on playback, but the export was full of clips. I just don't understand the mechanics of why this happens. The mystery continues...

rncbc's picture

are you sure the exported file sample-format is "Float 32-bit" ?
if yes then there's something really weird going on... it shouldn't ever clip when over 0dBfs like all the "Signed" (integer) formats...

cheers

Yup. The recorded files have no clipping. Playback when mixing has no clipping. However, the bounced files clip. I've experience this for 20yrs across Windows and Linux (so, not Qtractor specific.) I never understood why clipping has to be observed on the meters, but can't be heard when mixing. I can't tell you how many times I think I have the perfect mix, only to be disappointed on the bounced file. The simple answer is to not let them get hot through solutions like compression, or simply reducing gain. I wish I could hear the same clipping when mixing.

When I export the final mixdown to a .wav, I also get clipping even though the playback in Qtractor sounds normal.

What I've been doing for new projects is setting each track at a fairly low volume. That way the Master Output volume doesn't get close to zero when the song is finished. Then when I export it, there is no clipping in the exported .wav. Finally, I end up increasing the overall volume of the .wav song in Audacity.

rncbc's picture

again,
are you sure you're exporting to "WAV Microsoft" / "Float 32-bit" ?
and what are you using to listen to the exported files? if using it, isn't Audacity re-converting into a signed 16-bit sample-format on load?
byee

Thanks! I changed the export in Qtractor from Signed 16-bit to Float 32-bit like you suggested and now there's no clipping, even when the master output volume gets above zero. That's great, thanks again!

Add new comment