You are here

Configure: Qt 4.1 required for Qtractor 0.4.0 ?

I have Ubuntu 8.10 with Qt 4.0. "./configure" for new Qtractor fails with error "Qt 4.1 or greater is required". Is Qt >= 4.1 really required for Qtractor 0.4.0 or am I possibly doing something else wrong ? Web specs ( Qtractor / Requiremenst) indicate Qt 4.0 should be ok... ??


Arto Jääskeläinen

rncbc's picture

Yes, Qtractor requires Qt >= 4.1 and now that you're asking, Qt >= 4.2 is the stronguest recommendation though.

OTOH, you must have some outdated packages on your Ubuntu 8.10 as I've been packaging my .debs from Kubuntu 8.04, which is the LTS base I try to follow. Please, I believe there's nothing holding you on Qt4.0, not even KDE4 for that matter.


That error message faked me to think my Qt is less than 4.1 but no, it's actually v 4.4.3. So, having Qt 4.4.3 running I get that message claiming my Qt is <4.1 when I run ./configure under directory where Qtractor source is located.

I found myself solution for that Qt error message: After installing Qt developer things (Designer, Linguist, Creator) I was finally able to run ./Configure without that Qt 4.1 error but got stuck with something else:

checking for main in -ljack... no
configure: error: JACK library not found.

Getting a bit tired with this compilation project. A ready .deb package would be a lot easier for end users. Every musician is not a dedicated Linux program compilation expert.

In any case, I like your Qtractor and I shall not give up until it's running :-)


rncbc's picture

There's .deb available from the download page:

Please note that's built to Ubuntu 8.04 LTS. Might not work for you, though.

Anyway, you should be able to build it from source without problems, provided you have all the mandatory software requirements installed. Remember that you should install the corresponding development support packages, being those the ones with the -dev suffix in their name. You'll need, if my memory doesn't fail me,

  • Qt 4: libqt4-dev
  • JACK: libjack0-dev
  • ALSA: libasound2-dev
  • libsndfile: libasndfile1-dev
  • LADSPA: ladspa-dev
  • etc.
  • and try to comply with all suggested recommendations and dependencies you might get from your package management software, whatever it be.


Thanks, I already succeeded with your source and dev-libs. I got a .deb package of my own as a side effect (created by CheckInstall). Fyi, I tried to run the .deb package you gave but it fails with " liblo0 (>= 0.23)". This time I was using my Ubuntu 9.04 Jaunty. Never mind, that doesn't bother me since I was able to use your source. Qtractor looks good !

Hey art - any chance you'd make that deb available? My ubuntu jaunty only has version 3.0 available and I hate to go to all the trouble to compile a new one if you've already done it.

If there's anybody out there using Ubuntu-Studio (at the moment Ubunut jaunty with real time kernel) i could make a .deb for that. I think it creates a slightly different deb with the realtime kernel, doesn't it?

rncbc's picture

I'm no ubuntu-whatever authority, but there's no single reason any application packaging should depend on a specific kernel flavor. What might be an issue is the fundamental platform architecture baseline (glibc, gcc, ld, etc.), never the kernel.


You're right. Normaly there should not be a dependency. But I think to remember, that there has been a problem. I will try it out. Maybe in this case, I could provide a deb package...

Add new comment