You are here

Crash when loading Calf Analyzer Plugin

Dear Rui,

first of all thanks for your effort you put into qtractor and all the other plugins I quite often use! I'm just comparing it to other DAWs on my KXStudio 14.04 installation and I really like it so far. I prefer it to Ardour at the moment as I get results much faster and I really like the midi editor much better.
Like with Ardour also qtractor crashed several times and I wonder if the reason is my system (which normally shows no problems).

One crash which is quite (but not always) reproducible:

Loading the Calf Analyzer Plugin while something is playing into the Master Bus.
The terminal then tells me "floating point exception" and no more information.

I'm using Version: 0.9.0

Cheers,
Marco

Forums: 

Ahh... ok I see. How I can I restrict the installation to qt4 then?

rncbc's picture

you have to install a bunch of other development packages though (libqt4-dev) and bootstrap the build with ./configure --enable-qt4 ...

but, please take note that qt4 is deprecated and no longer supported: you are advised to move away from qt4 as much as you may possible can.

it is just unfortunate that kxstudio still relies on that for so long; im almost sure that most mainstream linux distros will ditch qt4 completely sooner then later, if not already done.

please go the other way: build the vee-ones on qt5 as it's the build default anyway.
cheers

trblft's picture

Hi,
I guess you already know that but it may be important :
https://github.com/calf-studio-gear/calf/issues/181
I upgraded calf-plugins but now every plugin crashes Qtractor.
Do I have to reinstall, or re-configure, or compile? It is 0.9.1 version on KXStudio repositories in UbuntuStudio 18.04.
Thanks.

rncbc's picture

there are at least one report that building qtractor on your own from source (and having gtk2.0-dev around at build time) might help (a lot:)).

hth.
cheers

copyc4t's picture

Debian unstable 64 bit here, no issues with:

calf-plugins 2:0.90.1-1kxstudio1
qtractor 2:0.9.1-1kxstudio2v5

In the past, I had the problem mentioned in the thread, with opening some Calf plugin GUIs (mostly the EQs) before playing any sound; now it's gone.

CALF plugins had a bug in the analyzer code (used in the EQs as well) when the GUI was opened before the first audio data came in.

Workaround: after starting Qtractor and loading a song first hit PLAY in Qtractor once before opening a CALF plugin's GUI.

Pages

Add new comment